Описание встроенного языка системы 1С Предприятие


Для


Оператор выполнения цикла.

Синтаксис:

Для <Имя_переменной> = <Выражение1> По <Выражение2> Цикл

   //Операторы;

КонецЦикла;

Англоязычный Синтаксис:

For <Имя_переменной> = <Выражение1> То <Выражение2> Do

   //Операторы;

EndDo;

Параметры:

<Имя_переменной>

Идентификатор переменной (счетчика цикла), значение которой автоматически увеличивается при каждом повторении цикла.

<Выражение 1>

Числовое выражение, которое задает на­чальное значение, присваиваемое счетчику цикла при первом проходе цикла.

По

Синтаксическая связка для параметра <Выражение2>.

<Выражение 2>

Максимальное значение счетчика цикла. Когда переменная Имя_переменной стано­вится больше чем <Выражение2>, выпол­нение оператора цикла Для прекращается. Величина приращения счетчика при каж­дом выполнении цикла равна 1.

Цикл

Операторы следующие за ключевым сло­вом Цикл выполняются, пока значение переменной Имя_переменной меньше зна­чения <Выражение2>.

//Операторы

Исполняемый оператор или последова­тельность таких операторов.

КонецЦикла

Ключевое слово, которое завершает струк­туру оператора цикла.

Описание:

Оператор цикла Для предназначен для циклического повторения операто­ров, находящиеся внутри конструкции Цикл ... КонецЦикла. Перед началом выполнения цикла значение <Выражение1> присваивается переменной <Имя_переменной>. Значение <Имя_переменной> автоматически увеличи­вается при каждом проходе цикла. Цикл выполняется пока значение перемен­ной <Имя_переменной> меньше или равно значению <Выражение2>. Вели­чина приращения счетчика при каждом выполнении цикла равна 1. Условие выполнения цикла всегда проверяется вначале, перед выполнением цикла.

Пример:

// Выведем все строки текста

Выв = СоздатьОбъект("Текст");

Выв.Открыть("ТТТ");

Для i = l по Выв.КоличествоСтрок() Цикл

   Сообщить(Выв.ПолучитьСтроку(i));

КонецЦикла;




- Начало -  - Назад -  - Вперед -